Coralbox D300 Loud

Discussion in 'Skimmers' started by Fats, Jul 30, 2017.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Users Viewing Thread (Users: 0, Guests: 0)

  1. Fats

    Fats Member

    Messages:
    38
    Ratings:
    +3
    Country:
    Australia
    State:
    QLD
    Hey so my new coral box keeps getting loud...its about 3 weeks old now, And every few days I have to pull it apart and re-seat the impeller as it gets loud. Once I re-seat it's near silent again but only for like 2-3 days......any suggestions/anyone also found this?
  2. somethingfishy76

    somethingfishy76 Member

    Messages:
    772
    Ratings:
    +720
    Country:
    Australia
    State:
    qld
    Id get straight onto Eric at fish street and let him know. It sounds like something is faulty.
    • Like Like x 2
  3. curly747

    curly747 Member

    Messages:
    172
    Ratings:
    +98
    Country:
    Australia
    State:
    NSW
    I have a coral box D500 and haven't had that problem. I did have to replace the pump a couple of weeks ago after about 2 years. Not great .. although the skimmer is going great now with the new pump. I would get onto fish street. They are pretty good at sorting thing out particularly if you give them some pictures or video of your problem.
    • Like Like x 1
  4. Fats

    Fats Member

    Messages:
    38
    Ratings:
    +3
    Country:
    Australia
    State:
    QLD
    Thanks guys will get onto to it....my best guess is the impeller does fit perfectly so after a couple days manages to move a bit and starts to rub/vibratre. Will Eric a message though.
  5. ReeferRob

    ReeferRob Solidarité

    Messages:
    2,593
    Ratings:
    +2,122
    Country:
    United States
    State:
    Maryland
    It sounds like the impeller is moving on the shaft which tells me it's out of spec. I have 3 of the DC300s on my private QT systems with no issues with them.

Share This Page